Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 28, 2019 - 15:21 GMT
Investigating
Some triggers are delayed
Posted 3 months ago. Feb 28, 2019 - 15:11 GMT
This incident affected: Workflow Triggers.