Degraded Application Performance
Incident Report for Tray.io
Resolved
This incident has been resolved and all our systems are operational.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Oct 26, 2023 - 09:31 BST
Monitoring
Our engineering teams have applied a fix and are currently monitoring the results. Users can now list solution instances both via the application and the public embedded API.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Oct 26, 2023 - 09:10 BST
Update
We are continuously investigating this issue and working on a resolution.

Users are not able to call the solutionInstances GraphQL query when interacting with the Tray Embedded API or list solution instances in the Tray application.

This incident is occurring in the US Tray region. The EU and APAC regions are completely unaffected and have been working as expected.
Posted Oct 26, 2023 - 08:38 BST
Identified
We have identified an issue causing unexpected behaviours within the Tray application. Users may see that some actions time out while using the application or the public GraphQL API.
Posted Oct 26, 2023 - 08:11 BST
This incident affected: Workflow Builder (Workflow Builder API, Workflow Builder App) and Embedded (Embedded API, Embedded App).