Degraded Gmail Trigger Performance
Incident Report for Tray.io
Resolved
This incident has been resolved and all our systems are operational.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Feb 26, 2024 - 22:16 GMT
Monitoring
Things are now back to normal. Customers will no longer see their Gmail events coming through delayed. The issue impacted our platform from 19:38 - 20:28 UTC. Our engineering team is currently monitoring the situation and continuing to investigate.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Feb 26, 2024 - 21:16 GMT
Update
Our engineering teams are continuing to investigate this incident. We will be back with more information as soon as possible. We are very sorry for any inconvenience this incident may cause.
Posted Feb 26, 2024 - 20:29 GMT
Investigating
We are currently investigating an issue that is causing unexpected behaviour within the Tray application. More specifically, it seems to be causing delays with the Gmail trigger.
If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Feb 26, 2024 - 20:03 GMT
This incident affected: Workflow Execution and Connectivity API (Triggers API).