Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 20 days ago. Jul 30, 2019 - 14:57 BST
Investigating
Some triggers are delayed
Posted 20 days ago. Jul 30, 2019 - 14:47 BST
This incident affected: Workflow Triggers.