Degraded Application Performance
Incident Report for Tray.io
Resolved
This incident has been resolved and all our systems are operational.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Dec 06, 2023 - 17:09 GMT
Update
We are continuing to monitor for any further issues.
Posted Dec 06, 2023 - 16:48 GMT
Monitoring
Application performance has returned to normal. We are currently monitoring performance.

Workflow executions (including API calls to Tray’s Connectivity API) may have taken longer to respond between 15:55 and 16:05 UTC.
Posted Dec 06, 2023 - 16:44 GMT
Investigating
We have identified an issue causing unexpected behaviours within the Tray application.

If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Dec 06, 2023 - 16:18 GMT
This incident affected: Workflow Execution and Connectivity API (Connectors API).