Degraded Application Performance
Incident Report for Tray.io
Resolved
This incident has been resolved and all our systems are operational.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Jan 26, 2024 - 18:01 GMT
Identified
Our engineering teams have identified the root cause of the issue. Users may see their workflow executions to be de delayed. We apologise for the inconvenience. Please reach out to support@tray.io if you have any questions or concerns.
Posted Jan 26, 2024 - 17:53 GMT
Investigating
We are currently investigating an issue that is causing unexpected behaviours within the Tray application.
If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Jan 26, 2024 - 17:44 GMT
This incident affected: Workflow Execution.