Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 8 days ago. Mar 13, 2019 - 05:11 GMT
Investigating
Some triggers are delayed
Posted 8 days ago. Mar 13, 2019 - 05:01 GMT
This incident affected: Workflow Triggers.