Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 03, 2019 - 10:36 BST
Investigating
Some triggers are delayed
Posted 5 months ago. Jun 03, 2019 - 10:06 BST
This incident affected: Workflow Triggers.