Degraded Workflow Trigger Performance
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted Nov 22, 2022 - 10:19 GMT
Monitoring
The primary issue has been resolved, though we are seeing residual effects with some customers continuing to experience delayed trigger initialisations.

If you have any questions or concerns, please feel free to reach out to support@tray.io. Thank you for your patience and understanding.
Posted Nov 21, 2022 - 22:50 GMT
Update
We are very sorry for this incident and any inconveniences it may have caused. Our engineering teams are continuously working on a resolution. However, users may still experience significant delays to general trigger initialisation. Workflow trigger initialisation may occur when a user makes a change to an enabled trigger or enables a workflow.

It is important to highlight that both workflow trigger firing and execution performance are completely healthy.
Posted Nov 21, 2022 - 22:10 GMT
Update
We've implemented a small fix which improved the firing performance of our third party triggers. In fact, we see no delays in the firing of these triggers anymore.

However, users may still see significant delays during general trigger initialisation, especially after new workflow creation.
Posted Nov 21, 2022 - 20:58 GMT
Investigating
Thank you for your patience while we have been investigating this incident. We are continuing to work on a full resolution. Delays to both third party trigger firings and general trigger initialisation are still ongoing but minor.
Posted Nov 21, 2022 - 19:57 GMT
Update
We are continuing to work on a fix for this issue. Users may still experience some minor delays to third party trigger firing and general trigger initialisation.

We will be back with further updates within 30 minutes or as soon as we have new information. If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Nov 21, 2022 - 19:15 GMT
Update
Our engineering teams are continuing to investigate the issue. We have made some changes which resulted in performance improvements. However, the incident is not yet fully resolved.

We will be back with further updates within 30 minutes or as soon as we have new information.
Posted Nov 21, 2022 - 18:38 GMT
Identified
We are looking into an issue which may cause some third party triggers to not fire on time. Users may also see some triggers to initialise slower than normal.

We are very sorry for any inconvenience this incident may cause. If you have any questions or concerns, please feel free to reach out to support@tray.io. Thank you for your patience and understanding.
Posted Nov 21, 2022 - 18:02 GMT
This incident affected: Workflow Execution.