Degraded Gmail Trigger Performance
Incident Report for Tray.io
Resolved
This incident has been resolved and all our systems are operational.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Feb 21, 2024 - 14:29 GMT
Monitoring
Our engineering teams have applied a fix and are currently monitoring the results. Customers will no longer see their Gmail events to be coming through delayed.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Feb 21, 2024 - 14:04 GMT
Identified
We've identified the issue and are currently working on a fix.

We will provide further updates as soon as additional information becomes available or no later than 30 minutes.

Thank you for your patience.
Posted Feb 21, 2024 - 13:56 GMT
Update
Our teams are actively working to resolve the issue causing delays in Gmail trigger events to come through. While progress is being made, we appreciate your continued patience.

We will provide further updates as soon as there is significant progress or within the next hour. Thank you for your understanding and cooperation.
Posted Feb 21, 2024 - 13:08 GMT
Update
Our engineering teams are actively working on resolving the issue. Customers may continue to experience delays in receiving some of their Gmail events.

If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Feb 21, 2024 - 12:22 GMT
Update
Our engineering teams are currently engaged in investigating this incident further.

Rest assured, we are dedicated to providing you with updates as soon as they become available. Thank you for your patience.
Posted Feb 21, 2024 - 11:17 GMT
Update
Customers who use the Gmail Trigger may see that their events are coming through delayed.

Our engineering teams are continuing to investigate this incident.

We will provide further updates as soon as additional information becomes available or no later than 30 minutes.
Posted Feb 21, 2024 - 10:50 GMT
Investigating
We are currently investigating an issue that is causing a degraded behaviour for the Gmail Trigger.

If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Feb 21, 2024 - 10:30 GMT
This incident affected: Workflow Execution and Connectivity API (Triggers API).