Execution Delays
Incident Report for Tray.io
Resolved
This incident is resolved, and workflow executions should be back to normal without delays. Please reach out to support@tray.io if you have any questions or concerns.
Posted Dec 20, 2023 - 21:14 GMT
Investigating
We are currently investigating an incident that may cause delays in workflow executions. We apologize for the inconvenience. Please reach out to support@tray.io if you have any questions or concerns on the matter, and we will continue to update here.
Posted Dec 20, 2023 - 20:59 GMT
This incident affected: Workflow Builder (Workflow Builder App).