Triggers and steps executions delays on the platform
Incident Report for Tray.io
Resolved
The incident has been resolved.
An internal cache became overloaded during a spike of executions. This slowed down the completion of executions until we were able to resolve the cache overload.

While we continue to review our logs, we believe that all affected executions will have been completed.
Posted Aug 17, 2020 - 22:45 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2020 - 23:52 BST
Investigating
There is a connectivity issue on the platform which impacts triggers and steps executions.
You may see executions delays in the Debug logs.
Posted Aug 13, 2020 - 23:35 BST
This incident affected: Workflow Execution.