Delayed Executions
Incident Report for Tray.io
Resolved
The incident has been resolved. Executions are running normally.
Posted Jun 24, 2021 - 18:45 BST
Monitoring
We have identified the issue and a fix has been implemented. Customers should see their executions returning to normal. We are still monitoring the situation.
Posted Jun 24, 2021 - 17:32 BST
Investigating
We are currently investigating an issue related to workflow execution. Some customers may see delayed executions in their workflows.
Posted Jun 24, 2021 - 17:16 BST
This incident affected: Workflow Execution.