Degraded Application Performance
Incident Report for Tray.io
Resolved
We have resolved the issue and are continuing to monitor performance on the application and the GraphQL API.

If you have any questions or concerns, please feel free to reach out to support@tray.io. We appreciate your patience and understanding.
Posted Oct 25, 2023 - 17:39 BST
Update
We are continuously investigating this issue.

If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Oct 25, 2023 - 16:30 BST
Investigating
We are continuously investigating this issue.

Users are not able to call the solutionInstances GraphQL query when interacting with the Tray Embedded API or list solution instances in the Tray application.

This incident is occurring in the US Tray region. The EU and APAC regions are completely unaffected and have been working as expected during the whole period of the incident.

Thank you for your patience and understanding.
Posted Oct 25, 2023 - 15:43 BST
Update
Our engineering teams are continuing to work on a fix for this issue.

Currently users are not able to call the solutionInstances GraphQL query when interacting with the Tray Embedded API or list solution instances in the Tray application.
Posted Oct 25, 2023 - 14:25 BST
Update
Our engineering teams are working on a fix.

Currently users are not able to call the solutionInstances GraphQL query when interacting with the Tray Embedded API.
Posted Oct 25, 2023 - 13:30 BST
Identified
Workflow executions are now operating as expected without any intermittent delays.

Users may still see some calls timing out while using the Tray application and the public GraphQL API.

We are continuing to work on fixing the issue.
Posted Oct 25, 2023 - 13:25 BST
Investigating
Users may see their workflow executions to run slightly slower than normal intermittently. We are continuing to investigate the issue and will be back with an update shortly.
Posted Oct 25, 2023 - 12:50 BST
Update
We experienced a performance degradation in our Connectivity API product from 12 pm to 12:10 pm (BST) today. Also, users who tried to log in to the application during this period may have been unable to do so.

We are continuing to work on a fix for this issue.
Posted Oct 25, 2023 - 12:24 BST
Identified
We have identified the issue and we are currently applying a fix. We will be back with a further update shortly.
Posted Oct 25, 2023 - 12:06 BST
Update
We are continuing to investigate this issue.
Posted Oct 25, 2023 - 11:38 BST
Investigating
We are currently investigating an issue that is causing unexpected behaviours within the Tray application. Users may see that some of their actions time out while using the application or our public GraphQL API.

If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Oct 25, 2023 - 11:37 BST
This incident affected: Embedded (Embedded API, Embedded App) and Workflow Builder (Workflow Builder App).