Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 12 days ago. Mar 09, 2019 - 19:41 GMT
Investigating
Some triggers are delayed
Posted 12 days ago. Mar 09, 2019 - 19:31 GMT
This incident affected: Workflow Triggers.