Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 29, 2018 - 15:37 GMT
Investigating
Some triggers are delayed
Posted 6 months ago. Nov 29, 2018 - 14:57 GMT
This incident affected: Workflow Triggers.