Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 13, 2019 - 05:46 GMT
Investigating
Some triggers are delayed
Posted 2 months ago. Mar 13, 2019 - 05:21 GMT
This incident affected: Workflow Triggers.