Workflow Trigger Outage
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 23:15 BST
Monitoring
We have implemented some additional fixes and workflow triggers should now be fully operational again.
Posted Jun 16, 2021 - 22:28 BST
Investigating
We have identified a small number of triggers that are still impacted by this incident. We are investigating the issue and will provide updates as soon as possible. Thank you for your continued patience and understanding.
Posted Jun 16, 2021 - 21:03 BST
Monitoring
The fix our engineers have put in place worked well. Therefore, our customers should not experience any more delays related to workflow triggers. We are currently monitoring the status of the application.
Posted Jun 16, 2021 - 19:54 BST
Update
We are continuing to work on resolving this issue. We will update this page as soon as we have more information to share.
Posted Jun 16, 2021 - 19:16 BST
Update
We are still working on reducing execution delays. We will update you as soon as latency has improved.
Posted Jun 16, 2021 - 18:31 BST
Update
Our engineers are implementing a fix at the moment which will reduce the delays customers are seeing in workflow triggers. We are also working on identifying the executions that did not fire. We will keep updating this page with new information.
Posted Jun 16, 2021 - 17:40 BST
Identified
We've been experiencing an outage related to workflow triggering since 3:30 PM (BST). Customers may see their executions being delayed or their workflows not firing. Our engineers are working to resolve the issue as soon as possible. We will update our Statuspage with new information shortly.
Posted Jun 16, 2021 - 16:53 BST
This incident affected: Workflow Execution.