Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 18 days ago. Oct 02, 2019 - 03:06 BST
Investigating
Some triggers are delayed
Posted 18 days ago. Oct 02, 2019 - 02:51 BST
This incident affected: Workflow Triggers.