Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted Jun 28, 2019 - 17:31 BST
Investigating
Some triggers are delayed
Posted Jun 28, 2019 - 17:21 BST