Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 17, 2019 - 03:11 BST
Investigating
Some triggers are delayed
Posted about 1 month ago. Jul 17, 2019 - 03:07 BST
This incident affected: Workflow Triggers.