Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 16 days ago. Oct 04, 2019 - 00:51 BST
Investigating
Some triggers are delayed
Posted 16 days ago. Oct 04, 2019 - 00:21 BST
This incident affected: Workflow Triggers.