Degraded Application Performance
Incident Report for Tray.io
Resolved
This incident has been resolved, and all our systems are operational.
Our backend services which handle workflow executions experienced an issue that caused degraded performance for a short period of time that caused slight delays to a small number of workflow executions. In addition, this may have caused some authentications to fail to refresh.
We apologize for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Aug 17, 2023 - 15:11 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2023 - 14:57 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 17, 2023 - 14:55 BST
Investigating
We are currently investigating an issue that is causing unexpected behaviours within the Tray application.
If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Aug 17, 2023 - 14:38 BST
This incident affected: Workflow Execution.