Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 18 days ago. May 08, 2019 - 17:36 BST
Investigating
Some triggers are delayed
Posted 18 days ago. May 08, 2019 - 17:22 BST
This incident affected: Workflow Triggers.