Application Degraded Performance
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 16:19 BST
Monitoring
Our engineering team has applied a fix and are currently monitoring the results.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io. Thank you for your patience and understanding.
Posted Jun 14, 2023 - 16:06 BST
Identified
We are currently investigating an issue that is causing unexpected behaviours within Tray application.
Posted Jun 14, 2023 - 15:52 BST
This incident affected: Workflow Execution, Workflow Builder (Workflow Builder API, Workflow Builder App, Workflow Builder Logs), Embedded (Embedded API, Embedded App), and Connectivity API (Connectors API).