Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 21 days ago. Jul 01, 2019 - 12:31 BST
Investigating
Some triggers are delayed
Posted 21 days ago. Jul 01, 2019 - 12:21 BST
This incident affected: Workflow Triggers.