Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 24 days ago. Jul 26, 2019 - 19:41 BST
Investigating
Some triggers are delayed
Posted 24 days ago. Jul 26, 2019 - 19:21 BST
This incident affected: Workflow Triggers.