Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 25, 2019 - 12:31 BST
Investigating
Some triggers are delayed
Posted about 2 months ago. Jun 25, 2019 - 12:22 BST
This incident affected: Workflow Triggers.