Degraded Application Performance
Incident Report for Tray.io
Resolved
This incident has been resolved.

We are very sorry for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io. Thank you for your patience and understanding.
Posted Jun 26, 2023 - 19:56 BST
Update
We are continuing to investigate this issue.
Posted Jun 26, 2023 - 19:41 BST
Update
We are continuing to investigate the issue, and we are seeing improvements.
Posted Jun 26, 2023 - 19:37 BST
Investigating
We are currently investigating an issue that is causing unexpected behaviours within the Tray application.
Posted Jun 26, 2023 - 19:24 BST
This incident affected: Workflow Execution, Workflow Builder (Workflow Builder API, Workflow Builder App, Workflow Builder Logs), Embedded (Embedded API, Embedded App), and Connectivity API (Connectors API).