Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 07, 2019 - 12:11 BST
Investigating
Some triggers are delayed
Posted 2 months ago. Jun 07, 2019 - 12:01 BST
This incident affected: Workflow Triggers.