Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 20 days ago. Mar 01, 2019 - 16:31 GMT
Investigating
Some triggers are delayed
Posted 20 days ago. Mar 01, 2019 - 16:06 GMT
This incident affected: Workflow Triggers.