Platform Slowness
Incident Report for Tray.io
Resolved
The incident has been resolved. Platform performance is back to normal.

Please reach out if you have any you have any questions, comments or concerns: support@tray.io
Posted Feb 25, 2022 - 01:45 GMT
Monitoring
We have implemented a fix and app performance has improved significantly. We are still monitoring for further developments.
Posted Feb 25, 2022 - 01:29 GMT
Identified
We have implemented a fix to address the issues with delayed triggers, customers should no longer see delays to triggers.

We are still looking into issues with creating authentications and the saving of workflow changes.
Posted Feb 25, 2022 - 01:02 GMT
Update
We are still looking into issues affecting platform slowness. A summary of known affected behaviour:

Some triggers may be delayed.
There are issues creating new authentications.
Changes to workflows may not be saved or might time out.

Thank you for your patience and understanding. If you have any questions, comments or concerns, please reach out to support@tray.io.
Posted Feb 25, 2022 - 00:38 GMT
Investigating
We have discovered additional issues affecting the creation of new authentications, we are looking into this also.
Posted Feb 25, 2022 - 00:03 GMT
Update
App accessibility has been improved, but we are still investigating issues which may cause some triggers to be delayed.
Posted Feb 24, 2022 - 23:33 GMT
Identified
We have found a potential cause of platform slowness and are working on a fix to address the issue.
Posted Feb 24, 2022 - 22:53 GMT
Investigating
We are currently investigating an issue preventing users from logging in to the app.
Posted Feb 24, 2022 - 22:19 GMT
This incident affected: Workflow Execution and Workflow Builder (Workflow Builder App).