Workflow Execution Slowness
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted Apr 26, 2023 - 17:45 BST
Identified
We have identified an issue that may cause a very small number of workflow executions to run slightly slower than normal. Our engineers are working on a fix.

If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Apr 26, 2023 - 13:51 BST
This incident affected: Workflow Execution.