Workflow Execution Slowness in the APAC region
Incident Report for Tray.io
Resolved
This incident has been resolved and all our systems are operational.

Users may have seen some execution slowness in the APAC region while the incident lasted.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted May 09, 2024 - 14:33 BST
Investigating
We are currently investigating an issue that is causing workflow execution slowness within the APAC region.

If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted May 09, 2024 - 14:16 BST
This incident affected: Workflow Execution.