Degraded Performance of the Workflow Builder
Incident Report for Tray.io
Resolved
We have implemented a fix and the Workflow Builder performance is back to fully operational again. This incident is now resolved.

We are very sorry for the inconveniences this incident may have caused.

If you have any questions or concerns, please feel free to reach out to support@tray.io.
Posted Jul 29, 2022 - 14:17 BST
Update
Our engineers have identified a fix that will significantly improve the performance of the Workflow Builder.
We will back with an update as soon as we implemented that change.
Posted Jul 29, 2022 - 14:02 BST
Identified
Our engineers have identified the root cause that causes delays to updates in the Workflow Builder. They are currently working on a fix to mitigate the issue.

We will be back with further updates within 30 minutes or as soon as we have new information.
Posted Jul 29, 2022 - 13:29 BST
Investigating
Users may experience delays between a step being added or changed and the change actually being reflected when the workflow is executed. Delays can be as long as 2 minutes, after making edits in the builder.

We will be back with further updates within 30 minutes or as soon as we have new information.
We apologise for any inconvenience this incident may cause.
Posted Jul 29, 2022 - 13:13 BST
This incident affected: Workflow Builder (Workflow Builder App).