Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 22, 2019 - 19:11 BST
Investigating
Some triggers are delayed
Posted 4 months ago. Apr 22, 2019 - 19:01 BST
This incident affected: Workflow Triggers.