Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 26, 2019 - 21:26 BST
Investigating
Some triggers are delayed
Posted 3 months ago. Jul 26, 2019 - 21:22 BST
This incident affected: Workflow Triggers.