Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 2 months ago. Jan 10, 2019 - 13:07 GMT
Investigating
Some triggers are delayed
Posted 2 months ago. Jan 10, 2019 - 12:57 GMT
This incident affected: Workflow Triggers.