Platform Slowness
Incident Report for Tray.io
Resolved
This incident has been resolved.

If you have any questions or concerns, please reach out to support@tray.io
Posted Mar 25, 2022 - 18:46 GMT
Monitoring
Application performance is back to normal, we are currently monitoring for any further developments.
Posted Mar 25, 2022 - 17:35 GMT
Update
Our engineers are continuing to investigate the issue, we have performed actions to rollback updates which were rolled out earlier today that were related to backend services.

We will be back with further updates within 30 minutes or as soon as we have new information.
Posted Mar 25, 2022 - 17:09 GMT
Investigating
We are currently investigating an issue which is causing platform slowness.

Customers may have trouble loading and accessing workflows from the application.
Posted Mar 25, 2022 - 16:31 GMT
This incident affected: Embedded (Embedded API, Embedded App) and Workflow Builder (Workflow Builder API, Workflow Builder App).