Degraded Application Performance
Incident Report for Tray.io
Resolved
Today we experienced a brief incident that caused delays in workflow executions and delays in executions retrying. It also resulted in some unexpected behaviour within the application. This occurred between 3:08pm UTC and 3:39pm UTC.

We are very sorry for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io. Thank you for your patience and understanding.
Posted May 17, 2023 - 17:22 BST
Investigating
We are currently investigating an issue that is causing delays to workflow executions and unexpected behaviour within the application.

We will be back with further updates within 30 minutes or as soon as we have new information.
We apologise for any inconvenience this incident may cause.
Posted May 17, 2023 - 16:31 BST
This incident affected: Workflow Execution, Workflow Builder (Workflow Builder API, Workflow Builder App), and Embedded (Embedded API, Embedded App).