Platform slowness
Incident Report for Tray.io
Resolved
The incident has been resolved.

If you have any questions or concerns, please reach out to support@tray.io
Posted Mar 04, 2022 - 17:46 GMT
Monitoring
Platform performance has improved significantly due to the fixes we have made. We are still monitoring the situation for any further developments.
Posted Mar 04, 2022 - 17:31 GMT
Identified
We have identified an issue which is causing platform slowness, we are currently implementing a fix to address these issues.

Customers may see delayed executions or workflows might be slow to save changes.
Posted Mar 04, 2022 - 17:14 GMT
This incident affected: Embedded (Embedded API, Embedded App), Workflow Execution, and Workflow Builder (Workflow Builder App).