Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted Jan 30, 2019 - 01:46 GMT
Investigating
Some triggers are delayed
Posted Jan 30, 2019 - 01:36 GMT