Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 21 days ago. Feb 28, 2019 - 15:46 GMT
Investigating
Some triggers are delayed
Posted 21 days ago. Feb 28, 2019 - 15:36 GMT
This incident affected: Workflow Triggers.