Schedule trigger delays
Incident Report for Tray.io
Resolved
Engineers have identified and patched an issue with the scheduling service for scheduled trigger operations. Certain edge cases were causing unnecessary latency in schedule processing which had a knock on delay to scheduled trigger execution.

All scheduled triggers are now back to normal and work is being done to mitigate any related future issues.
Posted Mar 19, 2020 - 23:06 GMT
Update
Scheduled triggers are currently delayed by up to 2 minutes due to capacity issues with underlying storage infrastructure. Engineers are still working towards fixing the issue and allowing scheduled triggers to catch up.
Posted Mar 19, 2020 - 18:52 GMT
Identified
We are currently seeing a delay in scheduled triggers. Engineers have identified the issue and are working towards a resolution.
Posted Mar 19, 2020 - 10:45 GMT
This incident affected: Workflow Execution.