Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 3 months ago. Nov 27, 2018 - 15:52 GMT
Investigating
Some triggers are delayed
Posted 3 months ago. Nov 27, 2018 - 15:42 GMT
This incident affected: Workflow Triggers.