Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 19 days ago. Jul 31, 2019 - 17:32 BST
Investigating
Some triggers are delayed
Posted 19 days ago. Jul 31, 2019 - 17:27 BST
This incident affected: Workflow Triggers.