Some triggers are delayed
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 02, 2019 - 12:30 BST
Investigating
Some triggers are delayed
Posted 3 months ago. Jul 02, 2019 - 12:21 BST
This incident affected: Workflow Triggers.