Several forms don't work on the website
Incident Report for Tray.io
Resolved
This incident has been resolved.
Posted Jul 15, 2016 - 15:31 BST
Identified
We have found that the following forms don't work:
- Demo request form
- Profile details form
- Password change form (in Profile page)

The issue has been identified and a fix will be released shortly.
Posted Jul 15, 2016 - 11:57 BST