Signup/Reset Password Not Working (Google reCAPTCHA Issue)
Incident Report for Tray.io
Resolved
Google reCAPTCHA issues have now been resolved and signup/password reset is available again.
Posted Mar 16, 2017 - 17:30 GMT
Update
If you are having trouble signing up to tray.io and you don't see the google reCAPTCHA box on the signup/reset password form, a solution is to visit this URL to solve the CAPTCHA there and then refresh the tray.io page: https://ipv4.google.com/sorry/index?continue=https://www.google.com/recaptcha/api.js&q=EgTUoQzmGN7CqsYFIhkA8aeDSwibkPlaI1zpzghrH5cCUCahjZ3vMgFj
Posted Mar 16, 2017 - 14:31 GMT
Identified
Google reCAPTCHA seems to be unavailable and is preventing new signups and password resets. We will continue to monitor and update when its back up.
Posted Mar 16, 2017 - 14:23 GMT