Degraded App Performance
Incident Report for Tray.io
Resolved
This incident has been resolved and all our systems are operational.

During the incident, some customers may have noticed minor delays to their executions and slow loading times.

We apologise for any inconvenience this incident may have caused. If you have any questions or concerns, please feel free to reach out to support@tray.io.

Thank you for your patience and understanding.
Posted Apr 12, 2024 - 01:06 BST
Investigating
We are investigating an issue causing degraded performance within the Tray application. Users may experience slow loading times and delayed executions. If you have any questions or concerns, please feel free to contact support@tray.io.
Posted Apr 12, 2024 - 00:33 BST
This incident affected: Workflow Execution and Workflow Builder (Workflow Builder App).